Issues

If you have any problems/questions or bugs to report please enter them as a comment at the end of this post. I’ll do what I can to help!

Known issues as of Nov2017:
– the version of Soundmanager2 API needs updating to the latest since our current version struggles on the latest iphones
– plugin currently only works on http but if you need https it’s a very quick fix, just ask me…
– Breaks siteorigin page buildr layouts.. sorry wish I could fix this but it’s not a simple one…

The comments from 2015 are about this plugin’s predecessor & they’re all fixed in this new version so hopefully we’ll do the same to these:)

best,
Rob

26 thoughts on “Issues

  1. We had an error on the install

    syntax error, unexpected T_STRING in /home/content/c/l/a/classicrockcof/html/wp-content/plugins/thefreemusician/ob_settings_v1_3.php on line 14

    Any idea why?

    1. hmmm… No but which version of wordpress are you using – I haven’t tested 3.7.1 yet… If you’re using it them I’ll get on that right away.

      Although to be honest I’m thinking it’s more likely a conflict with something else. That’s the first active line of that file that’s flagging an error. It’s not actually doing anything much so I’m thinking the actual error is elsewhere.

      What other plugins/theme are you using?

  2. Error on WP 3.7.1
    I got this error when installing:
    //Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_STRING in /home/heatherp/public_html/wp/test013/wp-content/plugins/thefreemusician/ob_settings_v1_3.php on line 14

    //

    other plugins installed are:
    Jetpack by WordPress.com
    thefreemusician
    Wordfence Security
    WordPress Database Backup
    WP Super Cache

    1. Many thanks for giving me the config/plugins. I will test it out when I get time. You’re the second person who’s reported that error. Unfortunately I won’t be able to do much with this til Jan. Any further work you do tracking the problem would of course be appreciated…
      Rob

    1. Wow, totally sublime music… What computer browser are you using to listen? It plays fine on mine. However… The facility to continue browsing the site while you listen is not currently enabled. If you want that to work you’ll have to go to settings -> TFM Player on your dashboard then set the ID and Menu ID parameters to ‘#content’ and ‘#botmenu’ and the AJAX Enabled parameter to ‘true’ (all without the quotes). Hope that helps,
      Rob

      1. Thanks for your fast reply! I actually figured it out, there was a script that was conflicting with your player, so I had to remove it from my header and then it started working.

        Thanks again! I have been looking for weeks for a good mp3 player for WordPress and yours is the first I found that looks and functions great. The others are all either one or the other!

  3. Hey, I get an error message wit 3.8.1 if I try to activate it.

    Parse error: syntax error, unexpected T_STRING in /home/www/web300/html/xxx_projects/xxx/wp-content/plugins/thefreemusician/ob_settings_v1_3.php on line 14

    could you help me?

    1. Just tried on a fresh 3.8.1 install and it works fine. However, I have had a couple of people report that error before so you’re not alone… Can you tell me which theme you’re using and which plugins you have installed please?

  4. Hi, I’m so glad for this plugin! I’ve been searching and searching for something to do this and am so so thankful to finally find one!
    I am having one major, major problem though. I have a static homepage (right now it just says ‘under construction’ but will eventually be a static something else). That page is set to display without sidebars while the rest of my site has sidebars. Now the problem is that when I set the AJAX setting to ‘true’ in the TFM settings, the rest of my site will inherent the no sidebar setting I have for my homepage. Obviously I want the sidebars on those pages, otherwise I would have had them turned off too. So the obvious solution to that seems to be, turn off AJAX but when I do that, my song won’t play anymore after navigating away from whatever page or post and that kinda defeats the whole purpose. So anyone have a suggestion? Thanks in advance!
    -angus (thehillandtheriver.com)
    P.S. I’m using the latest version of wordpress and the ‘suffusion’ theme.
    P.P.S. Again thanks for this amazing plugin, even if I can’t get it working with my theme it is still awesome!

    1. Thankyou for your kind words Angus.

      Go to Settings -> TFM Player and change the ‘id’ setting to ‘#container’ without the quotes. This will work *except* if you have any active (ie javascript) based content in the sidebar. If you have then it won’t load… However, it would be possible by hacking line 606 of thefreemusician.php so that it checks which page you’re on and sets the variable ‘tfmdivid’ to ‘#container’ when you are on the homepage and ‘#content’ when you are on any other page.

      Hope that helps:-).

      Rob

  5. Hi, your plugin works great as long as I leave Ajax disabled. When I enable it I can’t navigate. I’ve tried all kinds of different options. But I can’t seam to find a div id for the menu, I found a nav id though, but that doesn’t seam to work either.
    I als disabled all my plugins, but still no go. I’m using WordPress 3.9
    Any suggestions?

    1. Let me know which wordpress theme you’re using & I’ll tell you the settings. Or just point me to your test site & I’ll find out from there.
      Rob

        1. try #primary-navigation for ‘menu ID’ and #content for the ‘ID’ options – should work… Sorry for delay replying.

  6. I’ve installed your latest 0.6 in my WordPress 3.9.1, but it never ever works.
    I’d just tried to create an artist item, created an album item for that, and created 2 song items for that album.
    But when I browse that artist page, no any albums shown inside, and then when I browse that album page, so any songs shown inside!
    Why? please help me :'(

  7. Hi, I was wondering how to disable the plugin.
    I make AJAX enabled and now even if i switch it off, the links and the page still loads with ajax! Can you let me know how to get back to the previous state before activation?

    Thanks a lot. I am panicking now…

  8. Hi, I like the idea of this plugin but I can’t seem to get it to work. I’ve followed all of the instructions but the ‘Listen’ button still won’t play anything. I’ve using the Weaver II theme, and I don’t know how to find the correct ID or Menu ID for it. Thank you.

Leave a Reply

Your email address will not be published. Required fields are marked *